Problem with Billing and Account Management in North America 1 (US1), North America 2 (US2), Europe 1 (EU), Europe 2 (DE), Australia (AU), Japan (JP), Canada (CA), Korea (KR), America Federal (FED), Zurich (CH)
We are no longer seeing issues with Billing and Account Management and normal operation has been restored at this time.
Posted May 08, 2026 - 11:39 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 08, 2026 - 11:37 UTC
Identified
We have identified a technical issue affecting Billing and Account Management. Currently, Parent organisations are unable to manage Child organisations if a Mumbai (IN) region is included within the list.
Our engineering team is actively developing a fix. We apologise for the inconvenience and will provide updates as they become available.
Posted May 08, 2026 - 10:50 UTC
This incident affected: North America 1 (US1) (Billing and Account Management), North America 2 (US2) (Billing and Account Management), Europe 1 (EU) (Billing and Account Management), Europe 2 (DE) (Billing and Account Management), Australia (AU) (Billing and Account Management), Japan (JP) (Billing and Account Management), Canada (CA) (Billing and Account Management), Korea (KR) (Billing and Account Management), America Federal (FED) (Billing and Account Management), and Zurich (CH) (Billing and Account Management).