Problem with Microsoft Azure Metrics Collection in North America 2 (US2)

Incident Report for Sumo Logic

Resolved

We are no longer seeing issues with Microsoft Azure Metrics Collection and normal operation has been restored at this time.
Posted Jul 23, 2026 - 19:11 UTC

Monitoring

Microsoft Azure has identified and rolled back a change that was causing the networking issue in the West US region. We are seeing signs of recovery in our Azure Metrics Collection pipeline and expect processing latency to return to normal shortly.
Posted Jul 23, 2026 - 18:53 UTC

Identified

We have identified the source of the issue affecting Microsoft Azure Metrics Collection. The symptoms are: latency in processing and displaying metrics data. This issue is caused by a networking problem on Microsoft Azure's infrastructure in the West US region, which is impacting connectivity to Azure services. Microsoft is actively investigating and working on mitigation options for the affected network devices. We are monitoring the situation and will provide updates as Microsoft progresses toward a resolution.
Posted Jul 23, 2026 - 17:06 UTC