Problem with Billing and Account Management in Canada (CA)

Incident Report for Sumo Logic

Resolved

We are no longer seeing issues with Billing and Account Management and normal operation has been restored at this time.
Posted Jun 08, 2026 - 06:27 UTC

Monitoring

We have implemented a fix for the issue affecting Billing and Account Management, which are resulting in latency, slowness, or delay in displaying data. We are currently monitoring the results.
Posted Jun 08, 2026 - 06:24 UTC

Investigating

We are currently investigating reports of problems with Billing and Account Management, which are resulting in latency, slowness, or delay in displaying data. We will provide more information soon.
Posted Jun 08, 2026 - 06:07 UTC